IMPORTANT ANNOUNCEMENT: On May 6, 2024, Carbon Black User eXchange (UeX) and Case Management will move to a new platform!
The Community will be in read-only mode starting April 19th, 7:00 AM PDT. Check out the blog post!
You will still be able to use the case portal to create and interact with your support cases until the transition, view more information here!

App Control: Database Connection Fails Due to Single User Mode

App Control: Database Connection Fails Due to Single User Mode

Environment

  • App Control Server: All Supported Versions
  • Microsoft SQL Server: All Supported Versions

Symptoms

  • Console instability, including difficulty loading pages or logging in.
  • Errors in ParityReporter.log similar to:
    ERROR DatabaseConnectionWrapper - Database connection failed. Further database connect errors will not be logged. Login failed for user 'DOMAIN\ServiceAccount'. Reason: Server is in single user mode. Only one administrator can connect at this time.

Cause

The Restrict Access setting has been set to SINGLE_USER instead of MULTI_USER for the App Control database.

Resolution

  1. Log in to the application server hosting the Console as the Service Account.
  2. Stop the App Control Server and Reporter services.
  3. Open SQL Server Management Studio and connect to the SQL Server.
  4. Expand the Server Name > Databases > right click das > Properties.
  5. From the Options page > State > Restrict Access > select MULTI_USER.
  6. Click OK
  7. Start the App Control Server and Reporter services.

Related Content


Labels (1)
Was this article helpful? Yes No
No ratings
Article Information
Author:
Creation Date:
‎03-09-2023
Views:
232
Contributors