Environment
- App Control Agent: All Supported Versions
- Microsoft Windows: All Supported Versions
- Microsoft Active Directory
Symptoms
Cause
When Agents register with the Server they must be placed into the correct Policy. When Active Directory Policy Mapping has been configured, AD lookups must be completed to verify the correct membership.
When these LDAP queries made to Active Directory take very long time, the Server register threads get held up waiting on the results and cannot process Agent registrations
Resolution
- Log in to the Console and navigate to https://ServerAddress/shepherd_config.php
- Locate and adjust the following Properties accordingly:
- ADLookupThreads: 3
- ADLookupAsyncThresholdMs: 0
- Restart the App Control Server service.
Additional Notes
- Another possible symptom is high usage percentage for computer registrations in https://ServerAddress/support.php > Reports > Agent Traffic Stats.
- Currently there are no guidelines for ADLookupThreads per thousand Agents.
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