IMPORTANT ANNOUNCEMENT: On May 6, 2024, Carbon Black User eXchange (UeX) and Case Management will move to a new platform!
The Community will be in read-only mode starting April 19th, 7:00 AM PDT. Check out the blog post!
You will still be able to use the case portal to create and interact with your support cases until the transition, view more information here!

App Control: Upgrade Status: Upgrades Disabled

App Control: Upgrade Status: Upgrades Disabled

Environment

App Control Server: All Supported Versions

Symptoms

  • Agent shows "Upgrades Disabled" in the Upgrade Status column.
  • Inability to manually upgrade agents from Assets > Computers.
  • Inability to allow upgrades from the "Allow Upgrades" box in Policy Settings.

Cause

Global "Automatic Agent Upgrades" (Server 8.9 or Earlier) or "Allow Agent Upgrades" (Server 8.10 and Higher) setting is disabled.

Resolution

1. Navigate to Rules > Policies
2. For each policy, uncheck the "Allow Upgrades" box and click Save.
3. Navigate to System Configuration > Advanced Options tab.
4. Under "Carbon Black App Control Agent", enable "Automatic Agent Upgrades" (Server 8.9 or Earlier) or "Allow Agent Upgrades" (Server 8.10 and Higher) and click Save.
  • Enabling the "Allow Upgrades" (Server 8.9 or Earlier) or "Automatically Upgrade Agents" (Server 8.10 and Higher) box in Policy Settings will now trigger an upgrade for every endpoint in that policy.
  • Upgrades can now be initiated from Assets > Computers, checking the box next to an endpoint and clicking the Actions button, then 'Upgrade Agent'.

Additional Notes

To ensure that too large a number of endpoints aren't upgraded simultaneously, the "Allow Upgrades" (Server 8.9 or Earlier) or "Automatically Upgrade Agents" (Server 8.10 and Higher) option in Policy Settings should be used with caution.

Labels (1)
Was this article helpful? Yes No
100% helpful (1/1)
Article Information
Author:
Creation Date:
‎09-09-2020
Views:
3370
Contributors