Environment
- App Control Server: All Supported Versions
- App Control Agent: All Supported Versions
- Microsoft Windows; All Supported Versions
Symptoms
Cause
This error indicates that the endpoint has resolved the DNS name of the remote location, but cannot establish a connection with the remote location. Typically this happens when the port (such as 443) is blocked.
Microsoft defines this WinHttp Error[12029] as:
ERROR_WINHTTP_CANNOT_CONNECT: 12029
Returned if connection to the server failed.
Resolution
- Verify the Resource Download Location (RDL) specified is correct.
- Verify Port 443 to the RDL is open.
- Use PowerShell on the endpoint to test the connection:
tnc -ComputerName ServerAddress -Port 443 -InformationLevel "Detailed"
- Log in to the endpoint encountering the error and use a browser to validate the file exists and can be downloaded (without error), example:
https://ServerAddress/hostpkg/pkg.php?pkg=Yara.bt9
- Verify the Cipher Suites/Protocols enabled on the endpoint match those enabled on the application server.
- Manually import the problematic file on the endpoint (Yara, Configlist)
Related Content