Environment
App Control Server: 8.0 and Higher
Symptoms
- Server Address on the System Configuration > General tab shows as NONE
- API errors making some pages inaccessible
- Updating the Server Address results in a "Something Went Wrong" error message
Cause
The IP Address field is missing in the Parity.ini file.
Resolution
- Temporarily stop the App Control server and agent services.
- Back up a copy of C:\Program Files (x86)\Bit9\Parity Console\WebUI\Include\Parity.ini in case its needed in the future
- Modify the file C:\Program Files (x86)\Bit9\Parity Console\WebUI\Include\Parity.ini
- Verify that the Server Info is listed as:
[ServerInfo]
protocol=http
endpoint=127.0.0.1:41001
IP Address=FQDN of Server
Port=41002
Parity Version=INSTALLED VERSION
path="C:\Program Files (x86)\Bit9\Parity Server"
- Save the parity.ini file
- Start the App Control Server and Agent services
Related Content