IMPORTANT ANNOUNCEMENT: On May 6, 2024, Carbon Black User eXchange (UeX) and Case Management will move to a new platform!
The Community will be in read-only mode starting April 19th, 7:00 AM PDT. Check out the blog post!
You will still be able to use the case portal to create and interact with your support cases until the transition, view more information here!

CB Protection: Server Address listed as NONE after server upgrade

CB Protection: Server Address listed as NONE after server upgrade

Environment

App Control Server: 8.0 and Higher

Symptoms

  • Server Address on the System Configuration > General tab shows as NONE
  • API errors making some pages inaccessible 
  • Updating the Server Address results in a "Something Went Wrong" error message

Cause

The IP Address field is missing in the Parity.ini file. 

Resolution

  1. Temporarily stop the App Control server and agent services. 
  2. Back up a copy of C:\Program Files (x86)\Bit9\Parity Console\WebUI\Include\Parity.ini in case its needed in the future
  3. Modify the file C:\Program Files (x86)\Bit9\Parity Console\WebUI\Include\Parity.ini
  4. Verify that the Server Info is listed as:
    [ServerInfo]
    protocol=http
    endpoint=127.0.0.1:41001
    IP Address=FQDN of Server
    Port=41002
    Parity Version=INSTALLED VERSION
    path="C:\Program Files (x86)\Bit9\Parity Server"
  5. Save the parity.ini file
  6. Start the App Control Server and Agent services

Related Content


Labels (1)
Was this article helpful? Yes No
No ratings
Article Information
Author:
Creation Date:
‎09-09-2020
Views:
412
Contributors