Environment
Carbon Black Cloud: All Supported Versions
Microsoft Windows: All Supported Versions
Symptoms
- Sensor no longer checking in to the console
- Sensor Service (CB Defense) not running
- Windows Event Viewer System Logs shows entry similar to below:
Error - MM/DD/YYYY - Timestamp - Service Control Manager - Event ID:7000
A timeout was reached (45000 milliseconds) while waiting for the CbDefense service to connect.
The CbDefense service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion.
- Reboot does not automatically restart the service
- Manually restarting the Service succeeds, but may fail again post reboot
- Other Services set to Automatically start, also fail to start
Cause
Issues with resources on the Operating System are negatively affecting one or more Service
Resolution
- Increasing the timeout value for services (Default is 30000 milliseconds/30 Seconds) - This may need to be adjusted several times in order to find the suitable timeframe to allow services to start as expected
- Reference the example Microsoft KB Article below, which shows the procedure on how to amend/add the Timeout value
Additional Notes
Reported on Windows 10 Devices, but the resolution advice remains for other Supported Windows OS