IMPORTANT ANNOUNCEMENT: On May 6, 2024, Carbon Black User eXchange (UeX) and Case Management will move to a new platform!
The Community will be in read-only mode starting April 19th, 7:00 AM PDT. Check out the blog post!
You will still be able to use the case portal to create and interact with your support cases until the transition, view more information here!

Cb Protection: “Unable to Access Rules XML” Error

Cb Protection: “Unable to Access Rules XML” Error

Environment

Cb Protection Console: All Supported Versions

Symptoms

  • "Unable to access rules XML" Error when accessing Rules > Policies > Mappings tab within console
  • Cb Protection Server service crashes while trying to access mappings (seen in Event Viewer - System logs)

Cause

A group or OU that a policy mapping points to, no longer exists within Active Directory.

Resolution

  1. Login to the Cb Protection server.
  2. Open Services > Stop the CB Protection Server service
  3. Navigate to C:\Program Files (x86)\Bit9\Parity Server\scripts.
  4. Open the 'adrules.xml' with Notepad
  5. Remove any mappings that are no longer applicable and save the file
  6. Open SQL Mgmt Studio and run the following query to clear the DB copy of the file:
    use das; delete dbo.file_streams where name = 'adrules.xml'
  1. Start the CB Protection Server service

Additional Notes

Carbon Black has identified this issue internally as EP-4090

Labels (1)
Was this article helpful? Yes No
No ratings
Article Information
Author:
Creation Date:
‎11-20-2018
Views:
666
Contributors