Just Published! Threat Report: Exposing Malware in Linux-Based Multi-Cloud Environments | Download Now

Cb Response server update fails with dependency errors "Error: Package ... Requires: python-sqlalchemy >= 1.0.12

Cb Response server update fails with dependency errors "Error: Package ... Requires: python-sqlalchemy >= 1.0.12

Version

Cb Response server 5.x to 6.x update

Issue

"yum cb-enterprise update" fails with this error:

Error: Package: python-cb-coreservices-6.1.0.170405.0957-1.x86_64 (CarbonBlack)

Requires: python-sqlalchemy >= 1.0.12

Installed: python-sqlalchemy-0.7.10-1.x86_64 (@CarbonBlack)

python-sqlalchemy = 0.7.10-1

Symptoms

This command

yum --showduplicates list python-sqlalchemy

shows the required version  provided by CarbonBlack repo:    python-sqlalchemy.x86_64 1.0.12-1 CarbonBlack

Checking the alliance-client.crt by using this command and the test passes:

# curl -v --cert /etc/cb/certs/carbonblack-alliance-client.crt --key /etc/cb/certs/carbonblack-alliance-client.key https://api.alliance.carbonblack.com:443/api/v1/feeds

       About to connect() to api.alliance.carbonblack.com port 443 (#0)

              Trying 38.97.114.21... connected

               Connected to api.alliance.carbonblack.com (38.97.114.21) port 443 (#0)

This command

yum --disablerepo=* --enablerepo=CarbonBlack update python-sqlalchemy    <-- fails with these errors:

Finished Dependency Resolution

Error: Package: cb-datastore-6.1.1.170602.1049-1.el6.x86_64 (CarbonBlack)

Requires: java-1.8.0-openjdk-devel >= 1:1.8.0.91

Error: Package: python-cb-pysaml2-2.4.0-1.noarch (CarbonBlack)

Requires: pytz

Error: Package: cb-datagrid-6.1.1.170602.1049-1.el6.x86_64 (CarbonBlack)

Requires: java-1.8.0-openjdk-devel >= 1:1.8.0.91

Error: Package: cb-datagrid-6.1.1.170602.1049-1.el6.x86_64 (CarbonBlack)

Requires: java-1.8.0-openjdk >= 1:1.8.0.91

Error: Package: cb-datastore-6.1.1.170602.1049-1.el6.x86_64 (CarbonBlack)

Requires: java-1.8.0-openjdk >= 1:1.8.0.91

**********************************************************************

yum can be configured to try to resolve such errors by temporarily enabling

disabled repos and searching for missing dependencies.

To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d /search-disabled-repos.conf

**********************************************************************

Error: Package: cb-datastore-6.1.1.170602.1049-1.el6.x86_64 (CarbonBlack)

Requires: java-1.8.0-openjdk-devel >= 1:1.8.0.91

Error: Package: python-cb-pysaml2-2.4.0-1.noarch (CarbonBlack)

Requires: pytz

Error: Package: cb-datagrid-6.1.1.170602.1049-1.el6.x86_64 (CarbonBlack)

Requires: java-1.8.0-openjdk-devel >= 1:1.8.0.91

Error: Package: cb-datagrid-6.1.1.170602.1049-1.el6.x86_64 (CarbonBlack)

Requires: java-1.8.0-openjdk >= 1:1.8.0.91

Error: Package: cb-datastore-6.1.1.170602.1049-1.el6.x86_64 (CarbonBlack)

Requires: java-1.8.0-openjdk >= 1:1.8.0.91

Cause

Examining the "repo" files in /etc/yum.d.repos, it was found that every .repo file

except CarbonBlack.repo had a record:

           priority=1

The CarbonBlack.repo had no "priority" record.

Solution

1. edited every .repo and set priority=2 or higher

2. edited CarbonBlack.repo and set priority=1

3. re-ran  "yum cb-enterprise update"

4. optionally, reverse the priority designations, per the discrepancy of the Yum administrator.

Labels (1)
Was this article helpful? Yes No
No ratings
Article Information
Author:
Creation Date:
‎06-26-2017
Views:
935
Contributors