IMPORTANT ANNOUNCEMENT: On May 6, 2024, Carbon Black User eXchange (UeX) and Case Management will move to a new platform!
The Community will be in read-only mode starting April 19th, 7:00 AM PDT. Check out the blog post!
You will still be able to use the case portal to create and interact with your support cases until the transition, view more information here!

Endpoint Standard: Full Disk Access Not Shown as Enabled When Deployed Using MDM (JAMF PRO)

Endpoint Standard: Full Disk Access Not Shown as Enabled When Deployed Using MDM (JAMF PRO)

Environment

  • Endpoint Standard Sensor: 3.5.1.x - 3.5.2.x
  • Apple macOS: 11.0 and Higher (Big Sur)

Symptoms

Running repcli status command returns the following for FDA config:
Full Disk Access Configurations:
Repmgr: Not Configured
System Extension: Unknown
OSQuery: Unknown
Uninstall Helper: Unknown
Uninstall UI: Unknown

Cause

  1. Detection algorithm used by Sensor
  2. Operating System limitation related to correctly displaying this information when pushed via MDM profile

Resolution

The behavior is expected to be fixed in a future sensor release (3.5.3.x). Upgrade affected sensors to this version when it becomes available.

Additional Notes

  • As a workaround, Full Disk Access can be granted manually
  • Even after granting Full Disk Access via MDM (JAMF Pro) "com.carbonblack.defense.ui" is unchecked under the System Preferences, this is OS limitation

Related Content


Was this article helpful? Yes No
100% helpful (1/1)
Article Information
Author:
Creation Date:
‎03-05-2021
Views:
521