Version
Cb Protection (ALL)
Issue
Unable to automatically upgrade agents after the CB Protection server has been upgraded to a newer version
Symptoms
All computers in the Assets > Computers page show "Upgrade Disabled" and in the computer details for an agent you might see:
Upgrade Status: Upgrades disabled |
Cause
The "Automatic Agent Upgrades" function is disabled by default after upgrade in the System Configuration > Advanced Options section. This is to prevent unwanted automatic agent upgrades right after Server upgrade is completed. Policies with the checkbox for "Allow Upgrades" checked cannot upgrade agents without this global "Automatic Agent Upgrades"option being set back to 'Enabled'
Solution
To allow automatic agent upgrades based on the policy settings:
- go to Administration (Gear Icon in Version 8.0) > System Configuration > Advanced Options tab
- Then click the 'EDIT' button at the bottom of the page
- When sections are highlighted again, scroll up to the section heading "Bit9 Agent" (Or Cb Protection Agent in Version 8.0) and select the drop down for the option 'Automatic Agent Upgrades' and choose 'Enabled'
- Then, go back to the bottom of the screen and click 'UPDATE'
Additional Notes
Once "Automatic Agent Upgrades" is enable, all policies that have the "Allow Upgrades" box checked will attempt to upgrade those agents. If you wish to deploy upgrades to agents individually, then you will need to uncheck the "Allow Upgrades" in the policies BEFORE you enable "Automatic Agent Upgrades" in the System Configuration settings. This will allow you to select individual or groups of agents to upgrade at will.