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App Control: Disconnected agents after a recent server certificate update

App Control: Disconnected agents after a recent server certificate update

Environment

  • App Control Agent: Versions 8.1.8 - 8.1.10

Symptoms

  • After generating a new server certificate due to the previous one expiring some agent fail to reconnect back to the console
  • Trace.bt9 log with high debugging enabled shows:
Server Communication: WaitForResponse End: m_bIsSleeping[0] IsSleeping[0] GetHttpStatus[0]  GetWinHttpError[3]  GetSslError[0]  DataAvailable[0] 
Server Communication: WinHTTP communication error: 12017

Cause

The error matches a potential issue that exists in the 8.1.8 and 8.1.10 agents causing the agent to reject a newly issued server certificate

Resolution

  1. Please verify the issue is not caused by a common network misconfiguration using steps here 
  2. Please collect high debugging agent logs and open a support case using the steps here

Additional Notes

Agent versions 8.5+ should no longer run into this problem (EP-11588).

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Creation Date:
‎10-05-2020
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