Environment
- App Control Agent: All Supported Versions
- Microsoft Windows: All Supported Versions
Symptoms
Upgrade Status for Agent shows Reboot Required, rebooting does not resolve.
Cause
The upgrade failed on the endpoint and not all files required were properly replaced.
Resolution
Verify the versions being reported by the Agent on the endpoint, if they do not match a full
uninstall of the Agent and a reinstall will be required.
- Open an administrative command prompt on the endpoint and compare the Version Information of the CLI, Agent and Kernel by issuing the following commands:
cd "C:\Program Files (x86)\Bit9\Parity Agent"
dascli status
- Compare the file versions of "C:\Program Files (x86)\Bit9\Parity Agent\Parity.exe" and "C:\Windows\System32\Drivers\Parity.sys" to be sure they match.
If the versions match please open a case with Support and provide the most recent Agent Upgrade Log from "C:\ProgramData\Bit9\Parity Agent\Logs\ParityHostAgentInstall_TIMESTAMP.log".
Additional Notes
If reinstalling the Agent does not resolve the issue open a case with Support and provide the most recent Agent Install Log from "C:\ProgramData\Bit9\Parity Agent\Logs\Install_VERSION_TIMESTAMP.log".
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